Ummmmmmmmm

So I have a question to you all out there
I had my tubes done last yr as you know well I don’t remember when I last started was early April but I don’t know the date
Anyway I was having telltale symptoms so I tested the first was negative but after about an hour it was positive I assume evaporation line so I tested again this time a really faint positive right away then hard to see then about ten min later very obviously positive anyone have any thoughts
I will obviously retest if I don’t start soon but what the he’ll I’m sterile!

Advertisements

3 Comments (+add yours?)

  1. Carolyn
    May 01, 2009 @ 23:14:40

    Whoa! Now that is news!!! What the heck indeed?! Sorry about all the exclamation points, it’s just how I feel! I will await your update with baited breath.

    How is everything else? I hope work/life is going well.

    Reply

    • emmakirst
      May 02, 2009 @ 04:49:02

      All is going well… Aside from this of course
      I highly doubt it’s actually positive the chanced are insanely slim but still there is like a 0.01 percent LOL anyway I may just wait until Monday to retest because I was actually going to get the mirena I u d in for cycle control that’s what prompted all of this we will see

      Reply

  2. Kris
    May 03, 2009 @ 08:59:40

    Oh my goodness!

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: